Credit card charges failing
Incident Report for Elastic Cloud
Resolved
VISA has reported that it has resolved it's technical issues.
https://www.visaeurope.com/newsroom/news/visa-service-disruption
Posted 5 months ago. Jun 02, 2018 - 15:50 UTC
Update
The failed transactions are almost entirely VISA transactions. We believe this is related to widespread VISA issues.

https://www.bbc.com/news/business-44335804
Posted 5 months ago. Jun 01, 2018 - 16:21 UTC
Identified
We've identified an issue with our credit card processor failing an excessive number of transactions.

You might have received an email about a failed charge due to this, even though there is nothing wrong with your credit card.

Your clusters are safe, no account suspensions will be triggered while we look into this.
Posted 5 months ago. Jun 01, 2018 - 16:11 UTC